(Ayuda) Aplicaciones xul no inician


(Jose Manuel Rufo) #1

Hola a todos compañeros.

Soy nuevo en este grupo y también en el mundo del desarrollo de interfaces con XUL.

Seguramente mi pregunta es de novatos. He seguido todas las indicaciones para instalar xulrunner y me encuentro con el problema que cuando intento iniciar una aplicación no se me abre ninguna ventana y tampoco me lanza ningún tipo de error.

He realizado las mismas operaciones en otro equipo y si funciona a la perfección.

¿Alguién sabría decirme que puede ser lo que este haciendo que en mi equipo no se lance la aplicación?.

Tengo funcionando Mozilla y lo utilizo a diario tanto la versión de usuario como la de desarrolladores.

Un saludo a todos y gracias de antemano.


(Alexander J. Salas B.) #2

Hola Jose.

Corre esta app a ver:

Saludos.


(Jose Manuel Rufo) #3

Hola Alexander.

Gracias por tú pronta respuesta y ayuda, pero sigo con el mismo problema.

Al ejecutar desde la línea de comandos la aplicación está no lanza la vetana que muestra la interface.

Un saludo.


(Rubén Martín) #4

Una nota: Mozilla quiere dejar de usar XUL en un futuro cercano por lo que si estás empezando un proyecto yo no te recomendaría basarlo en esta tecnología. Tenlo en cuenta.


(Alexander J. Salas B.) #5

¿Que versión de XULRunner tienes?

¿En que sistema operativo?

La app la ejecutas así: xulrunner application.ini

O si usas Windows puedes agarrar el binario xulrunner-stub y lo colocas en
la raíz del proyecto y ese será tu ejecutable.

Así sea descontinuado XUL igual se seguirá usando xulrunner, hubieron
comentarios también de dejar de atender xurunner pero fueron criticados, y
son solo comentarios.

Lo extraño es que xulrunner ya no sea para xul y entonces se llame ahora
htmlrunner jaja. Ya webrunner es parte del Proyecto Prism que dio también
paso a las nuevas apps desktop del Marketplace.

Por Telegram puedo ayudarte: http://telegram.me/alexandersalas